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Welcome to Extensis Intellihance. You've just purchased an intelligent
tool that makes Adobe Photoshop work faster, easier, and more effi-
ciently than ever before.

Intellihance improves the way your digital images appear in print or on
the screen by automatically applying filters for contrast, brightness,
saturation, sharpness, and despeckle. You can customize the way
Intellihance applies filters—choose from menus of predefined prefer-
ences or use the Fine Tune option for absolute control.

After you determine the way you want your output to appear, you can
save your preferences and get the same results when applied to multiple
images.

Before Intellihance After Intellihance

We've tested Intellihance for compatibility with other applications that
use Adobe Photoshop Plug-ins. For example, if your QuarkXPress
(with QX-Tools) or PageMaker 6.0 document includes images from
another source, you can run Intellihance on those images from inside
PageMaker.

Note: While Intellihance should be compatible with all applications
that accept Adobe Photoshop Plug-ins, not all applications have been
thoroughly tested.



E Intellihance Standard Install

You get everything you need to run
Intellihance.

Installation requires: 1819K

System and Software Requirements
To use Intellihance, you need the following equipment and software:

» An Apple Macintosh with a 68030-25MHz processor or faster, or any
Power PC-equipped Macintosh.

» System software version 7.1 or later.

» Adobe Photoshop 2.5.1 or later, or other applications that accept
Photoshop Plug-ins.

Note: If you're using Adobe Photoshop 2.5.1 or non-Photoshop
applications, allocate enough additional RAM to equal 1.4 times the
image size.

Software Installation

» To install Intellihance:

1. Insert the Intellihance disk into the disk drive.
2. Double-click the “Intellihance Installer” icon to open it.
The Intellihance introduction screen appears.

3. Click the Continue button.

The Welcome to Intellihance dialog box appears. The release notes
in this dialog box contain important information not included in the
manual. It's a good idea to save or print these release notes before
continuing with the installation.

4. Click the Continue button.

The Intellihance Standard Install dialog box appears. You can
choose the complete installation that includes a color separation
tables folder, a bad pictures examples folder, and all Intellihance
filters: GS (grayscale), RGB, and CMYK. You can also choose a
Custom installation where you install only what you need.

5. Click the Install button.
The disk selection dialog box appears.

6. Select the application into which you want to install
Intellihance. Then click the Install button.

Intellihance User Manual 5
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The installation program will locate the appropriate Plug-in folder
and begin installing. After installation is complete, the successful
installation dialog box appears. You can choose to quit the Installer
or continue to install Intellihance filters to other applications.

7. Click the Quit button.

Registration

It is important to register your copy of Intellihance so we can provide
you with service. Registered users of Intellihance are eligible for
technical support, information regarding new versions and products,
and discounts and special offers on new products.

Intellihance includes electronic registration, so registering has never
been easier! The first time Adobe Photoshop is launched after
Intellihance is installed, the Intellihance Personalize dialog box
appears. To personalize Intellihance, type your name, company, and
Intellihance registration number. Your product registration number is
located on your Intellihance disk. If you choose not to personalize your
copy, Intellihance will run in a demonstration mode that lets you
process five images.

After you have personalized Intellihance, a dialog box appears asking
if you would like to register. To register Intellihance, click the Register
Intellihance button and an electronic registration screen appears. After
you've completed the registration screen, a Market Research screen
and a System Configuration screen will follow. The Market Research
screen asks basic questions which enable us to better understand your
needs. The System Configuration screen provides a “snapshot” of your
system configuration which enables Extensis to support you more
effectively. Sending the Market Research and System Configuration
information is optional, if you don’'t want to send this information to
Extensis, you may check the checkbox at the bottom of these screens.

If you have a modem connected to your computer, you can register
toll-free by modem. If you do not have a modem, you can print the
registration sheet and register either by faxing it to (503) 274-0530 or
mail it using the postage-paid envelope provided. If you don’t have
access to a modem or printer, you can still register by filling out a
registration sheet located at the end of this manual.



Tip

You can send us a Fax at 503-
274-0530, or contact us through
one of these online services:

CompuServe : 70242,33
America Online : EXTENSIS
AppleLink : EXTENSIS
Eworld : Extensis1

Technical Support

If you have a question or problem that is not addressed in this manual,
please call technical support53-274-7030ionday through Friday,
between the hours of 8:00 a.m. to 5:00 p.m., Pacific time.

When calling Technical Support, please be at your Macintosh and have
the following information available.

* Your Intellihance registration number.
e Your Macintosh configuration.

*  Your question or a description of the difficulty you're experienc-
ing—what specifically occurs and when. Write down any displayed
error numbers or messages and any other information you think
may be helpful.

Suggestions

We'd love to hear your comments about Intellihance, ideas for new
plug-ins, or improvements to Intellihance. A suggestion sheet is
included at the end of this manual. Please fax or mail your comments
and suggestions to Extensis.

Intellihance User Manual 7
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Intellihance improves the way your images appear in print or on the
screen by automatically adjusting the contrast, brightness, saturation,
sharpness, and despeckle of your output images. Intellihance measures
the amount of these effects in your original image, compares the
measurements with the preferences table, and then automatically
processes the image to match the preferences.

The Intellihance default preferences are based on the way most people
like to view images in print or on the screen. The best way for you to
decide if you like the default settings is to try them. Process three or
four images with Intellihance and look at the results. If you like what
you see, the default settings are fine for you.

The following table lists the Intellihance default settings. If you want to
change the default preferences, go on to the next section, “Customizing
Intellihance.”

Intellihance Filter Default setting
Contrast Normal

Brightness Balanced Tone
Saturation Off

Sharpness Medium Sharpness
Despeckle Off

The following procedure tells you how to use Intellihance with its
default settings—simply open an image in Adobe Photoshop, select the
Intellihance filter, and click OK. That’s all there is to it!



» To process an image with Intellihance default settings:

1. From Adobe Photoshop, open an image you’'d like to process.

2. Bring up the Intellihance Preview screen by choosing Filter >
Intellihance > RGB or CMYK or GS.

Intellihance automatically makes available the appropriate
Grayscale, RGB, or CMYK filter for your image in the pull-down
menu (the other filters are not available).

3. From the Intellihance Preview screen, click OK to process the
image.

The Preview screen shows you the original image and the enhance-
ments that Intellihance proposes to make when you process it.

The Preview Screen

Your original image.

A preview of the filter adjustments
Intellihance will make to the image.

When you move your mouse over an
original or preview image, the pointer
becomes a crosshair. Move the crosshair
over the Original or Preview image to see
the pixel readouts % in CMYK, RGB, or
Grayscale values.

Click Cancel to exit the Preview screen.
Click OK to process the image.

Click this tab to customize the way
Intellihance applies its filters.

Click for information about Intellihance and
Technical support.

Help messages.

P 9
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Customizing Intellihance

You can customize the way Intellihance applies the contrast, brightness,
saturation, sharpness, and despeckle filters. Choose from popup menus
of predefined effects or use the Fine Tune option for manual control.

Intellihance compares your original image to the output settings you've
chosen—and then automatically processes the image to match your
preferences. You determine the way you want your output to appear,
make those selections from the menus in the Intellihance Preferences
screen, and click OK to apply the changes. Then you can apply the
same set of preferences to multiple images. You can also save different
preference settings and load them at a later time.

The Preferences Screen

A

Click to display menus that determine how
your output image will look.

Intellihance will start processing the
current image with the output settings
defined in the Preferences panel (Return).

Exits Intellihance with no changes
(Command-period).

Selects a file of previously saved settings
and load them in the Intellihance
Preferences screen (Command-L).

Saves the current preference into a folder
and file of your choice (Command-S).

Displays the Fine Tune screen that allows
you to manually adjust your image
(Command-F).

To always go directly to the Fine Tune
screen when you open Intellihance, select
this checkbox.

Click for information about Intellihance and
Technical Support.

® 0O @O
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Adjusting Intellihance Filters

You can adjust five separate filters from the Intellihance Preferences
screen. Each filter has a menu of predefined effects.

» Contrast

* Brightness

Saturation (available with RGB and CMYK only)
e Sharpness

Despeckle



off
Soft
& MNormal

Snappy
Hard Contrast

Flatten Shadows
Flatten Highlight=

Contrast

The Contrast filter gives you four options for adjusting tonal correction.
TheNormal option will brighten highlights, darken shadows, and
establish midtones for best overall contrast. Selecddiftsoption if

you want to maintain maximum shadow and highlight detail or if you
want to lower contrast overall. Select teappyoption if you want

your image to have solid blacks and solid whites or to increase contrast.
Select theHard Contrast option if you want images with high contrast

or if you want a posterized effect. If you don't want any correction, you
can turn this filteOff .

Two additional options are available for special publishing applications.
Flatten Highlights may be useful when printing on newspaper to allow
you to use the paper itself to represent the highlight in the image.
Flatten Shadowsmay be useful when you want to push some shadow
noise into the blacks.

Soft Contrast

Hard Contrast

For a color example of this filter, refer to the inside front cover of this manual.

Intellihance User Manual 11



Brightness

Off The Brightness filter adjusts or shifts various tonal groups. You can
Deeper Shadows shift shadows, midtones, or highlights, or balance the overall tone of
Shadow Emphaziz the image. This means, for example, that Intellihance can darken

® Balanced Tone overexposed photographs and lighten underexposed photographs. If
Midtone Emphasis you don’t want any correction, you can turn this filbgf.
Highlight Emphasis Brightness is a subjective adjustment. Try each of the settings for the

Brightness filter and see what you like best. After running the settings
on several images, you'll discover which setting provides the most
desirable results.

Balanced Tone

Deeper Shadows Highlight Emphasis

For a color example of this filter, refer to the inside front cover of this manual.
12 Intellihance User Manual



w Off
Liowr
Fediurm Lo
Fediurm
Fediurn High
High

off
Soft

®& fedium Sharpness
Hard Sharpness
Extra Hard

Saturation

The Saturation filter (available with RGB and CMYK only) is a color
correction filter for automatically adjusting the purity of the color. The
Medium option provides excellent results for most images. Intellihance
automatically examines the saturation of the input image and then will
increase or decrease the saturation according to the setting for this filter.
This is very useful with Photo CD images that are often oversaturated.

If you don’t want any saturation correction, you can turn this fir

Saturation processing will increase the computing time. Unless you
have a powerful Macintosh, you might want to allow extra time to
process images that need more saturation.

Sharpness

The Sharpness filter sharpens soft images by increasing the contrast of
adjacent pixels. Like Brightness, Sharpness is also subjective. Try each
of the settings for the Sharpness filter on several images and see what
you like best. If you don’t want any correction, you can turn this filter
Off. Remember, the Sharpness filter will not sharpen noisy images.

Note: On large images, the Preview screen may exaggerate the sharp-
ening effects.

Soft Sharpness

Extra Hard Sharpness

For a color example of Saturation and Sharpness filters, refer to the inside front
cover of this manual.
Intellihance User Manual 13
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Despeckle

The Despeckle filter removes noise, such as photograin or scanner-
induced noise, while preserving detail. Intellihance detects the edges in
an image (the areas where significant color changes occur) and gently
smooths all of the selection except those edges.

If you want to reduce image noise, this filter has three options that will
process only noisy pixels without changing highlights or other details.

The Overall option is useful for situations where the image may
contain speckles or photograin noise in the image Didrk Tones

Only option is for images where you're satisfied with your light tones
and only need to adjust dark tones. Tight Tones Only option is for
images you might enlarge such that the photograin in the highlights
becomes evident. These last two options allow you to limit the filtering
to the darker or lighter areas of the image. If you don’t want any
correction, you can turn this filt€dff.

See “Scanning Tips” later in this manual for a simple method to assess
scanner noise.

Note: On large images, the Preview screen may exaggerate the
Despeckle effects.

Using the Intellihance Fine Tune Option

Although the power of Intellihance lies primarily in its ability to
automatically correct and enhance images with little or no user inter-
vention, you may want specific control of the filter adjustments. You
can use the Fine Tune screen to accomplish this. The preview window
shows you the effect of each adjustment. You can preview your original
image—without the effects—by holding down the Option key.

Note: Intellihance processes the image with the automatic settings
before you make any adjustments in the Fine Tune screen.



The Fine Tune Screen

A Click these tabs to display controls for
each filter.

B Click for information about Intellihance or
Technical Support.

C Click to apply adjustments to the image
(Return).

D Exits Intellihance with no changes
(Command-period).

E Returns to the settings of the original
image, before running Intellihance
(Command-C).

F Returns to the settings in effect when the
Fine Tune screen was selected
(Command-R).

G Press the Option key to preview the
original image (before Intellihance).

H Help messages.

R LT
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Imape 1

H
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- |
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Tip

To display the Fine Tune screen
every time you open
Intellihance, select the Fine
Tune Always checkbox from the
Preferences settings in the
Intellihance Preview screen.
Then, every time you press
Command-F to open
Intellihance, the Fine Tune
screen appears.

» To manually fine tune an image:

1.

Bring up the Intellihance Preview screen by choosing Filter >
Intellihance > RGB or CMYK or GS.

You can also press Command-Option-F.

Click the Fine Tune... button or press Command-F.
The Fine Tune screen appears.

Select the tab for the filter you want to adjust.
Move each slider to your desired position.

Intellihance will filter the image using the measurements from the
slider positions—while you watch.

The order in which you apply the filters affects the output. We recom-
mend you use the following order.

1.

Set the Tone. Set the white point as low as you can without
flattening important highlights. Set the black point as high as you
can without flattening the shadow data. Set the gamma or midtone
point for a balanced tone or to emphasize a key element in the
image.

Intellihance User Manual 15
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2. Adjust the Sharpness. Sharpness can amplify noise if not applied
correctly. Set the radius at 2 or 3 depending on the ppi of the scan,
set the Amount % between 30-120%, and set the Threshold
between 0-20. Note that on large images, the Preview screen will
exaggerate the sharpening effects.

3. Remove noise. The Despeckle filter reduces image noise. Set the
lower limit and upper limit to determine when noise removal
begins and ends. Typically, this filter is applied in the shadows.
Note that on large images, the Preview screen will exaggerate the
blurring effects.

4. Adjust Saturation.

For more information about each of the controls in the Fine Tune
screen, see “Enhancement Tips” later in this manual.

Color Separation Table

When you want to convert RGB images to CMYK, you can use the
PixelCraft ColorAccess professional color separation table included
with Intellihance. RGB scanners, Photo CD disks, and stock photogra-
phy disks produce RGB images that must be converted to CMYK for
printing. If you've ever performed these separations using other CMYK
separation tables, you may have noticed:

e Color shifts in color you thought would be pure.
» Posterization, or a flattening of highly saturated colors.

e Overall image darkness and a lack of definition in the shadows or
dull highlights.

* An overall magenta cast.
* A brownish cast in the shadows.

The PixelCraft separation table, included on the Intellihance disk,
produces better separations because the separation table maps the RGB
color gamut to the most printable CMYK colors. This reduces common
problems with CYMK separations that print too much ink.

The PixelCraft color separation table was set up especially for
Intellihance. PixelCraft separation tables are based on industry-standard
“Skeletal Black” black generation algorithms and industry standard ink
sets. The table included with Intellihance emulates a sheet-fed offset
press using a commercial ink set on coated paper stock.



Tip

The Separation Tables dialog
box also converts CMYK images
to RGB for viewing CMYK data
on the screen.

» To use the color separation table:

1.

From the File menu, choose Preferences > Separation Tables....
The Separation Tables dialog box displays.

Click the Load button.

The File Load dialog box displays.

Find the PixelCraft separation table in the Plug-ins folder on
your hard drive.

Select the PixelCraft separation table and click OK.

This table name displays next to the Use Table radio buttons and
will be used in all RGB to CMYK separations and to view all
CMYK data instead of Adobe Photoshop’s Printing Inks Setup
whenever you use Adobe Photoshop.

. Select Mode > CMYK color.

You'll watch the image change from RGB to CMYK color space.

To improve color separation results:

Calibrate the Printing Inks Setup in Adobe Photoshop.

Follow the calibration procedure @alibrating Your Systenin the
Adobe Photoshop manual for entering the Printing Inks Setup
information.

Calibrate your monitor for tone correction.

Follow the calibration procedure @alibrating Your Systenin the
Adobe Photoshop manual.

To improve Photo CD results:

From the Intellihance Preference screen, set the Saturation filter
to Medium.

A Medium Saturation filter will compensate for Photo CD images
that are typically oversaturated and overexposed.

Open your Photo CD image and convert it to a Lab image in
Adobe Photoshop (Mode > Lab Color).

Intellihance User Manual 17
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o gk~ w

Select the L channel by pressing Command-1.
Run the Intellihance GS (grayscale) filter on the L channel.
View the entire image by pressing Command-0.

If needed, run the appropriate Intellihance filter on the entire
image.

Saving and Loading Intellihance Filter Settings

After you set up Intellihance Filters with the specific adjustments you
want, you can save these settings and then use them automatically.

>

To save filter adjustments:

1.

o N

v

Bring up the Intellihance Preview screen by choosing Filter >
Intellihance > RGB or CMYK or GS.

You can also press Command-Option-F.

Make sure all the popup menus display the settings you want.
Click the Save Settings button or press Command-S.

Select a folder and a name for the settings file.

Click Save.

To load filter adjustments previously saved:

Bring up the Intellihance Preview screen by choosing Filter >
Intellihance > RGB or CMYK or GS.

You can also press Command-Option-F.

Click the Load Settings button or press Command-L.
Select the folder and name of the settings file to use.

4. Click Open.

The Intellihance Preferences screen now displays your saved
settings in the popup menus.
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Generating a Report of Changes to the Image

If you would like to see what Intellihance has done to the image, you
can generate a report by holding down the Option key as the filter
finishes processing. The report gives you parameters that emulate
(although not exactly) Adobe Photoshop Levels and Unsharp Mask
settings.

Notice the Saturation Factor value. This is an indication of how much
the saturation increased or decreased. A value of 1.0 indicates Satura-
tion was unchanged. Desaturation occurs when this value is less than
1.0. To use this value in Adobe Photoshop, multiply this number by 100
and copy into the Hue/Saturation dialog box.

The % Despeckled value indicates what percentage of the image’s
pixels were filtered as noise pixels.

Intellihance User Manual 19
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Tip

If you have either QuicKeys or
PhotoMatic macro application,
you can convert a batch of RGB
images to CMYK. Use the
IntelliCMYK3 macro for
Photoshop 3.0 and InteliCMYK2
macro for Photoshop 2.5.1.

Intellihance User Manual

While Intellihance is perfectly suited for most users right out of the
box, advanced users can benefit from the full set of Intellihance
features.

This section tells you how to process multiple images; improve the
quality of your scanned images; further enhance your output images;
calibrate your monitor to more accurately display images on-screen;
process images for duotones, tritones, and quadtones; and improve the
printed quality of your output images.

Processing Multiple Images

If you have a macro-generating software application, such as QuicKeys
or PhotoMatic, you can use one of the templates that comes with
Intellihance to convert RGB images to CMYK or to automatically
process several different images at the same time. Procedures for using
Intellihance with each macro application follow.

The images must be saved from Adobe Photoshop as a Macintosh TIFF
or EPS format. Make sure you choose the template that matches your
version of Adobe Photoshop.

Note: For more information about using macros with Intellihance, refer
to the manual that came with your macro application.

Using QuicKeys to process multiple images

To use the macro application QuicKeys, you'll first prepare the images
for processing before you actually process them.

» To prepare multiple images for QuicKeys processing:

1. Place the images you want to process into a separate folder and
give it a title, such as “RGB Images.”

These images should all be of the same filter set, for example, RGB.

2. Move the IntelliBatch macro from the IntelliBatch folder into
your new RGB Images folder. Then view the contents by Name.

Make sure you use IntelliBatch3 for Photoshop 3.0 and

IntelliBatch2 for Photoshop 2.5.1. The IntelliBatch macro has a
space before its name to guarantee it appears at the beginning of the
list.

3. Open one of the images you want to process from Adobe
Photoshop.



. From the Filter menu, choose the Intellihance filter that
matches the filter set of the images you want to process.

The Intellihance Preview screen displays.

. Choose the setting you want for each filter in the Preferences
screen. Then click OK.

Run Intellihance once to establish your preferences in global
memory, which also makes Intellihance the current filter.

. Choose Save As... from the File menu, enter the filename
“dummy image,” and click OK.

Make sure you are saving in the RGB Images folder that you
created.

. From the Finder, throw away the dummy image.

This sets the current Save as... directory. You are now ready to begin
processing all the images in your RGB Images folder.

To process multiple images with QuicKeys:

. Make sure you have enough room on your disk to save a new
processed copy of each image.

. Double-click the IntelliBatch macro icon in your RGB Images
folder.

The Repeat Extension dialog box displays asking for the number of
times you want to run the macro.

. Enter the number of images you want to process and click OK.

The macro will now process each image. Saved copies of each
processed image have a tick mark (°) at the beginning of the
filename. Intellihance will now automatically process the remaining
images. If you want to add other steps to the macro, or if you need
to modify the macro for your environment, go on to the next
procedure.
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File Edit Define

» To change the QuicKeys IntelliBatch macro:

‘% Eegin Repeat
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@ W ait not watch
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T tiek
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1. Bring up the QuicKeys Main dialog and select Open set...
2. Find the IntelliBatch folder and select the IntelliBatch Keyset
file.

Make sure you are viewing the user sequence macros. You should
see four IntelliBatch macros in this folder.

w

Double-click the macro you want to change.
4. Modify the macro the way you want.

P To save the new macro as an icon file:
1. Bring up the QuicKeys Main dialog from the Apple menu.
2. Select the macro you want to save.
3. From the File menu, select the Make Icon command.
A Save as... dialog box appears.
4. Rename the macro with a leading space in the name.

5. Check the Save shortcut data in OK Icon checkbox and click the
Save button.

Your new macro is how ready to use.

Note: For more information about using macros with Intellihance, refer
to the QuicKeys manual.

Using PhotoMatic to process multiple images

PhotoMatic 2.0 from Daystar is an Apple Script-based batch processing
system. You can get the latest version of PhotoMatic for no charge
from the DayStar web site: http://www.daystar.com. You can use the
PhotoMatic template included on your Intellihance disk, or you can
make your own script.

Refer to the PhotoMatic manual for instructions to make your own
script. You can include Intellihance as part of your script along with
other Adobe Photoshop commmands.

Note: PhotoMatic only operates with Adobe Photoshop, whereas
QuicKeys can be used with any application.



» To prepare multiple images for PhotoMatic processing:

1.

Move the PhotoMatic IntelliBatch scripts into the Adobe
Photoshop > Scripts folder.

This makes them available for use from the PhotoMatic Play Back
menu.

. Open an image in Photoshop that matches the type of images

(GS, RGB, or CMYK) you want to process.

Bring up Intellihance by choosing Filter > Intellihance > RGB
or CMYK or GS. Set the preferences the way you want them
and click OK to process the image.

This sets up Intellihance preferences and makes Intellihance the
current filter.

Choose Edit > Undo to undo the Intellihance processing from
step 3.

From the PhotoMatic menu, select Play Back > IntelliBatch
Macro. Then close the macro without saving it.

This tests the script. Make sure you use IntelliBatch3 for Photoshop
3.0 and IntelliBatch2 for Photoshop 2.5.1. Also, make sure you use
the correct mode for the type of images you're processing.

Place all the images you want to process into a separate folder.
Make sure all the images are the same type (GS, RGB, or CMYK).
Move the IntelliBatch macro from the IntelliBatch folder into

your new folder.

Make sure you use IntelliBatch3 for Photoshop 3.0 and
IntelliBatch2 for Photoshop 2.5.1. Also, make sure you use the
correct mode for the type of images you're processing.

. Open the PhotoMatic folder. Drag and drop the folder of images

onto the PhotoMatic icon.

If PhotoMatic asks you to select a copy of Photoshop, select the
copy that is currently running.

Look for the processed images in the Done folder.

The images will be processed and put into the Done folder inside
your Photoshop folder.

Note: For more information about other batch processing methods or
making your own scripts with Intellihance, refer to the manual that
came with PhotoMatic.
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Tip

Turning off your scanner’s
automatic features will capture
all the available data in the
image. If this makes the image
dark, Intellihance will automati-
cally compensate.

A & 0z

A good scan. Notice the smooth tapering of the
shadow and highlight data.

- & 2

The white point is too low. Notice the spike at the
whitest point, indicating that highlight data has
been flattened. This means the highlight data
was scanned as white because these values
were whiter than the scanner’s white point.

A & A
The white point is too high. Notice the bunching

of data at the darkest point, indicating that the
shadow data has been flattened.
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Scanning Tips

You can use your scanner interface to control your scanner’s brightness,
color cast, white point, and scan resolution.

Most scanner interfaces have various controls to set brightness,
contrast, gamma, highlight, and shadow points. These controls, if used
improperly, can add noise or flatten the highlights and shadows of the
image. That's why it's best to turn off your scanner’s automatic
features.

P To evaluate your scanner’s capabilities:

1. Open an image from Adobe Photoshop.
2. Choose Adjust > Levels from the Image menu.

The Levels dialog box displays showing the distribution of pixel
values in your image.

Checking your scanner’s white point

You can improve scans by properly setting your scanner’s white point,
that is, the reflective value the scanner sees as white or 0%. If you
picture is overly bright and the scanner’s white point is low, you may
be flattening your highlight data. This is especially noticeable when
scanning a calibration strip or an image with a broad tonal range.

Refer to the documentation provided in your scanner’s manual to set
the white point. Sometimes the brightness control can be used to set the
white point of the scanner. If you can’'t seem to adjust the white point
properly, you may have a scanner that doesn't allow you to set the
white point; these scanners typically perform the manipulation in
software.



Tip
Use this formula to calculate the
pixels per inch:

ppi = Ipi x 1.5 x scale factor

Determining whether to use the Despeckle filter

You can view speckles or noise to determine whether to use the
Intellihance Despeckle filter. Noise can be previewed directly by
turning up or increasing the contrast in the tones to an extreme. If the
speckles are severe, set the Despeckle filter menu to Dark Tones Only
from the Intellihance Preference screen. This will suppress shadow
noise. If you are processing a batch of images with severe photo grain
noise, set the Despeckle filter menu to Overall.

Determining the scan resolution

The capability of your output device determines the correct resolution
for a scan. As a general rule, to produce a high-quality halftone image,
the image resolution (measured in pixels-per-inch or ppi) should be 1.5-
2 times the lines-per-inch (Ipi) value of the halftone screen used to print
the image. For example, to print a high-quality image using a 133-Ipi
screen, you would need an image resolution between 200 and 266 ppi
(133 x 1.5 to 2.0). In some cases, however, depending on the image and
the output device, ratios of as low as 1.25 produce excellent results.

The size of the final image compared to the original image is also a
consideration in setting scan resolution. If the final output size is not
known, then overscan by a larger factor. For more information about
determining the final output size, refer to your scanner’'s manual.

If you see excessive noise in your scans, your scanner may be taking
short cuts. Even though you want a scan at 225 ppi, many scanners will
scan the picture at 300 ppi and remove pixels electronically. In the case
of high resolution scans, it is common for a scanner to scan at 600 ppi
and add pixels to get 1200 ppi. This may result in speckle artifacts or
blurring. If you see excessive scanner noise, try scanning at 300 or 600
dpi and then scale the image in Adobe Photoshop. Remember the scale
factor affects the scan ppi.

For more information about determining the scan resolution, refer to
Scanning, Importing, and Exporting Imageshe Adobe Photoshop
manual.
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Enhancement Tips

After you have processed an image with Intellihance, there are three
ways to further enhance the image.

1. Run Intellihance on the image again.
2. Use the Fine Tune adjustments.

3. Use other Adobe Photoshop filters and tools. Refer to the Adobe
Photoshop manual for more information about image enhance-
ment.

Running Intellihance on the image again

When Intellihance processes an image, it compares the input to the
settings in the Preferences screen and decides which filters to run to
make the output conform to those settings. Sometimes you can run
Intellihance again to gradually bring the image closer and closer to your
preferences.

You can also run Intellihance again to bring out the effects of a specific
filter. For example, maybe the sharpness of the image is good, but you
want more brightness. If you set the Sharpness filter to Off and run
Intellihance again, the Brightness filter continues to improve the
brightness of the image.

Try running Intellihance with the Despeckle filter set to Dark Tones
Only, and all other filters turned Off. This will clean up shadow
speckles caused by excessive scanner noise.

Using the Fine Tune adjustment

When you click the Fine Tune... button in the Intellihance Preview
screen, you can adjust sliders for Tone, Saturation, Sharpness, and
Despeckle.

Tone

When you select the Tone tab, the Tone panel appears. The first slider
adjusts the shadow (dark tone) values in your image to become black,
or the Black Point. The available numerical values are 0 to 253, where
0 is black (or 100% solid). Notice that if you adjust the Black Point to a
value higher than the Mid Point, the mid point value slides up also.



The second slider adjusts the middle tone values in your image. You
can adjust this slider from 0 to 254. If your image contains middle
tones (say, 25-75%) that you would like to darken or lighten overall,
adjust this slider. Mid Point, normally considered to be 50%, is repre-
sented by the value 128.

The third slider adjusts the light tone values in your image to become
white, or the White Point. You can adjust this slider from 2 to 255,
where 255 is white (or 0% tone).

Saturation

When you select the Saturation tab, the Saturation panel appears. The
slider bar is calibrated in percentage with 0% in the center, -100% on

the left side, and +100% on the right side. A positive percentage value
increases the color, but not the neutral or gray value in your image. A
negative value decreases the color saturation. In other words, a satu-
rated color tends to be brighter, and a desaturated color tends to stay the
same.

Sharpness

When you select the Sharpness tab, the Sharpness panel appears. The
Amount % slider bar has numerical values from 0 to 200%. The
Amount % increases relative sharpness of the image. The Radius slider
bar has values that range from one pixel to three pixels. Radius estab-
lishes the width of the sharpened edges. The Threshold slider bar has
values that range from 0 to 255. Higher Threshold settings reduce
sharpening of pixel and photo grain noise. We recommend values no
greater than 20.

Despeckle

When you select the Despeckle tab, the Despeckle panel appears. The
Amount % slider bar has numerical values from 0 to 200%. This slider
sets the amount of pixel noise removed. The Lower Limit slider bar has
values from 0 to 254. This value establishes the lowest level (darkest
tone) at which despeckling or noise remdwadjins The Upper Limit

slider has values from 2 to 255. This value establishes the highest level
(lightest tone) at which noise remoeadds For example, if you want

to despeckle or remove noise in the shadow tones only, set the lower
limit to O and the upper limit to 64.
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Tip
# of shades = (dpi/lpi)?

Ipi = dpi / V# of shades
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Monitor Calibration Tips

If you want to use your monitor to evaluate halftones and color images
on the screen (commonly referred to as “soft proofing”), you must
calibrate your monitor. To reliably soft proof an image can save time
and money in proofs and printing jobs.

Calibration is the process of adjusting your monitor with the color
conversion parameters to compensate for various factors that affect
both the on-screen image and its conversion to printed output. These
factors include room lighting conditions, the type of viewing light
source, and the quality and settings of your monitor and display card.

For a comprehensive instructions about how to calibrate your monitor,
refer toCalibrating Your Systenm the Adobe Photoshop User Guide.

Printing Tips

After you've processed your image so that you're satisfied with it, the
next step is to prepare the image for your output device. You need to set
the Ipi of your output image and then of your output device.

Setting the Ipi of your output image

Selecting the Ipi of your printer or imagesetter has a dramatic effect on
the quality of your printed image. The human eye needs to see at least
64 gray levels for good tonal evaluation. This is why you should
consider your output printing requirements before you begin setting the
ppi of your scanner. If you plan to photocopy, laser print, or quick print,
don’t use line screens over 100 Ipi.

Note: In most cases, you can use the setting for your printer’s default
screen ruling located in your graphics application.

If not, calculate the best Ipi for your printer based on the resolution of
the printer (dpi), the line screen frequency (Ipi), and the number of
shades in your halftone.



Setting the Ipi for your laser printer

Use the following table for setting the Ipi of your laser printer.

Printer dpi Ipi # shades optimal for

300 53 32

600 72 65 600 dpi laser proofing
600 85 50 newsprint proofing
800 100 64

800 85 88 newsprint proofing
1000 133 56 high resolution
1000 120 69 better tone

1000 100 100

1200 150 64 high resolution
1200 133 81 better tone

1200 100 120

For example, if you have a 600 dpi laser printer, you should use 72 Ipi.
This provides 64 shades of gray. A setting of 85 Ipi could also be used
in proofing newsprint, which provides about 50 shades of gray.

Setting the Ipi for your imagesetter

Imagesetters typically have a dpi of 2400 or greater. At this resolution
level, it is the press that will determine the Ipi. A sheet-fed, offset press
can reproduce screens as fine as 200 Ipi or higher. Since many factors
determine the maximum Ipi of the press, you should consult your print
vendor for this information.

Intellihance User Manual 29



30

Intellihance User Manual

Multitone Tips

Duotones, Tritones, and Quadtones (multitones) are useful in creating
sepia, old photo, and other colorization and special effects. Using two,
three, or four inks to reproduce a single channel image not only creates
these wonderful effects, but also increases the tonal depth of the image.
In either case, Intellihance can be used to increase the effectiveness and
consistency of Duotones, Tritones, and Quadtones.

Processing an image for Multitone reproduction

When processing an image for Multitone reproduction, it is often
desirable to spread the tone of the image over the entire dynamic range,
sharpen it, and then remove noise from the image. Intellihance does all
this for you automatically.

If the image is old, you should set the Despeckle filter to Dark Tones
Only. You might want to preserve some of the image’s softness by
setting the Contrast filter to Soft. Now the image is ready to print as a
Multitone.

Converting an image to Multitone

The Adobe Photoshop manual describes several ways to convert an
image to a standard Duotone, Tritone, or Quadtone. You can continue to
use Intellihance on these images after they’'ve been converted.



Glossary

bitmapped An image formed by a rectangular grid of pixels. The
computer assigns a value to each pixel, from one bit of information
(black or white), to as much as 24 bits per pixel for full color images.

calibration Setting equipment to a standard measure to produce
reliable results from input to output. See atsanitor calibration

CMYK (Cyan, Magenta, Yellow, Black) The subtractive primaries, or
process colors, used in color printing. Black (K) is usually added to
enhance contrast and to print a true black.

color correction The process of adjusting an image to compensate for
scanner deficiencies or for the characteristics of the output device, or
the original film.

contrast The relationship between the lightest and darkest areas of an
image.

dpi (dots per inch) A common measurement for describing the
resolution of input and output devices. See pfso

duotone Seemultitone

gamma Measures the contrast that affects the midlevel grays
(midtones) of an image. Adjusting the gamma lets you change the
brightness values of the middle range of gray tones without dramati-
cally altering the shadows and highlights.

grayscale The depiction of gray tones between black and white.

halftone screen A pattern of dots of different sizes used to simulate a
continuous tone photograph, either in color or black and white.

Lab The Lab color model is based on the original color model pro-
posed by the Commission Internationale d’Eclairage (CIE) in 1931 as
an international standard for color measurement.

Ipi (lines per inch) A measure of the frequency of a halftone screen
(usually ranging from 55-200). Originally, halftones were made by
placing an etched glass plate over an image and exposing it to produce
dots. Lpi refers to the frequency of the horizontal and vertical lines.

monitor calibration The process of correcting the color rendition
settings of a monitor to match the colors of printed output.

multitone Used to integrate one or more colors into a grayscale image
for a design effect.
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pixel (picture element) The smallest distinct unit of a bitmapped
image.

pixelization If the image resolution is too low, the PostScript language
may use the color value of a single pixel to create several halftone dots
when printing. This results jpixelization or blocky-looking output.
posterization A flattening of highly saturated colors.

ppi (pixels per inch) A measure of the amount of scanned information.
The finer the optics of the scanner, the higher the scan resolution.
guadtone Seemultitone

RGB (Red, Green, Blue) The additive primary colors used for com-
puter monitor displays.

saturation The strength or purity of color. Saturation represents the
amount of gray in proportion to the hue and is measured as a percent-
age from 0% (gray) to 100% (fully saturated).

screen frequency The number of lines or dots per inch on a halftone
screen. Same as Ipi.

tritone Seemultitone
white point The reflective value that a scanner sees as white or 0%.
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Common Questions

Will Intellihance process every image correctly?

Intellihance processes most images in an optimum way. Users have
experienced a 1-7% fallout, although it is interesting to note that often

it is hard to improve the fallout images beyond that of images processed
by Intellihance, even when starting from scratch. If image quality
degrades after running Intellihance with its default preferences, try
turning Contrast and/or Brightness preference settings Off and running
Intellihance again.

What Scanners does Intellihance work with?

Intellihance works with all scanners—you can optimize images from
any source.

Will Intellihance work with my color management system?
Intellihance works well with color management systems both inside
and outside of Adobe Photoshop.

Does Intellihance require that my scanner be calibrated?

Because Intellihance operates on color balance principles, it works with
both calibrated and uncalibrated scanners.

Can I run Intellihance multiple times?

Yes, running Intellihance again will bring the image even closer to your
preferences.

Must | calibrate my monitor when using Intellihance?

If you plan to use the monitor display to evaluate the quality of the
image before you print, it is very helpful—although not required—to
calibrate your monitor. If you are evaluating grayscale images on the
monitor, then calibrate your monitor using the monitor preferences in
Adobe Photoshop. If you are evaluating color images on your monitor,
you should use a color calibration system.

My image looks good on the monitor, but not in print.

You may need to calibrate your output device or monitor, or both. Refer
to Chapter 3, “Advanced Tips,” in this manual for more information.

My image lacks contrast.

Try reducing the Limits and Dot Gain from Adobe Photoshop. Also, try
increasing the Contrast filter setting or decreasing the Brightness
setting in the Intellihance Preferences screen.
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Registration

If you haven't already registered, please complete the following registration information,
tear along the perforation and fax to (503) 274-0530 or mail it in the postage-paid
envelope provided. Your product registration number is located on the Intellihance disk.

Registration Number

Name

Organization

Street Address

City State Country Zip/Postal Code
Daytime Phone Daytime Fax

e-mail (optional) CIS AOL A-Link GEnie InterNet Other

Hardware Configuration(check all that apply)

0 PowerMac 0 Quadra 0 Mac Il any O QuarkXPress for Windows

0 CD-ROM 0 Modem 0 Scanner [ Do you also use a PC running Windows?
O PowerBook O Network

QuarkXPress Experiencécheck one)

O <6 months O06mo.—1yr. O1lyr—-2yrs. [O3-5yrs. O >5yrs.
Number of personal computers at sieheck one)

o1 02-5 0 6-10 0 11-25 0 26-50 0 >50

How did you learn about Intellihance®check all that apply)

0O Advertisement O Review O Bundle O Demo O Dealer
O Word-of mouth O User Group [ Direct Malil O Other

Where did you purchase Intellihance?

What publications do you read@heck all that apply)

0 MacWorld 0 MacUser 0 MacWEEK 0 Adobe O Publish
0 X-Ray 0 Other

Other Graphics/Publishing Application Used(heck all that apply)

O Photoshop O Ilustrator O FreeHand 0 PageMaker O Persuasion
0 Kai's Power ToolsO KPT Bryce 0 KPT Convolver [0 KPT Vector Effects O Fetch

O Live Picture [ Debabelizer O Painter O Texture Maker O Premiere
0 XPosure 0 The Black Box O Paint Alchemy [ Acrobat 0 Word

0 WordPerfect 0 Write Now 0 MacWrite 0 ClarisWorks O Excel

0 MS Works O Quicken O FileMaker O Cytopia Photolab O Ofoto

0 ScanPrepPro 0 PhotoFlash O PhotoMatic O Specular Collage 0O Canvas
0 QuicKeys 0 Gallery Effects 0 KPT 0 QuarkXPress

Other Utilities Applications Usedfcheck all that apply)

O AfterDark O Now Utilities 00 RAM Doubler [0 MacTools [ Norton Utilities

O Compression O Spell Checker O Stock Photo O Clip Art
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Suggestions

We'd like to know what you think we could do to make Intellihance
better. So if you have an idea for a new product feature, a modification
to an existing one, or anything else you can think of that will help us
make Intellihance better—we’d like to hear from you.

To help make Intellihance better, please...

1. Print your name, address, and phone number below and sign your
name.

2. Describe your idea or comment.
3. Tear along the perforation and mail or fax this sheet to Extensis.

| understand that no compensation will be awarded for my suggestion.

My suggestion is...

Name

Street Address

City State Country Zip/Postal Code
Daytime Phone Daytime Fax

Thanks for your suggestions! Hopefully you'll see your ideas in future
versions of Intellihance or other Extensis products.
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